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Application Kit — with complete product documentation on disk.
• Getting Started instructions.

• Plastic and metal standoffs with 4-40 screws and washers.

• A bag of accessory parts for use on the Prototyping Board.

• Rabbit 4000 Processor Easy Reference poster.

• Registration card.

Run a Sample Program
Once the RCM4300 is connected as described in the preceding pages, start Dynamic C by double-clicking on the 
Dynamic C icon on your desktop or in your Start menu. Select Code and BIOS in RAM on the “Compiler” 
tab in the Dynamic C Options > Project Options menu. Then click on the “Communications” tab and verify 
that Use USB to Serial Converter is selected to support the USB programming cable. Click OK.

NOTE: The Code and BIOS in RAM BIOS memory compiler option is recommended while debug-
ging for faster download times. Remember to recompile the working application using the Code and 
BIOS in Flash, Run in RAM option once you are ready to use the RCM4300 in a standalone instal-
lation.

Determine which COM port was assigned to the USB programming cable on your PC. Open Control Panel > 
System > Hardware > Device Manager > Ports and identify which COM port is used for the USB connec-
tion. In Dynamic C, select Options > Project Options, then select this COM port on the Communications 
tab, then click OK. You may type the COM port number followed by Enter on your computer keyboard if the 
COM port number is outside the range on the dropdown menu.

Use the File menu to open the sample program PONG.C, which is in the Dynamic C SAMPLES folder. Press 
function key F9 to compile and run the program.The STDIO window will open on your PC and will display a 
small square bouncing around in a box.

Where Do I Go From Here?
If the sample program ran fine, you are now ready to go on to other sample programs, which are discussed in 
Application Note AN417, Secure Embedded Web Application Kit 2.0. The source code for the sample programs 
is provided to allow you to modify them for your own use. The RCM4300 User's Manual on the Dynamic C CD 
also provides complete hardware reference information and describes the software function calls for the 
RCM4300 RabbitCore modules and the Prototyping Board. Each Dynamic C module has complete documenta-
tion on the Dynamic C CD that describes the Dynamic C module and discusses the function calls and sample pro-
grams associated with the Dynamic C module.

Troubleshooting
If Dynamic C cannot find the target system (error message "No Rabbit Processor Detected."):

• Check that the RCM4300 is powered correctly — the red PWR LED on the Prototyping Board should be lit 
when the RCM4300 is mounted on the Prototyping Board and the AC adapter is plugged in.

• Check both ends of the programming cable to ensure that they are firmly plugged into the PC and the PROG 
connector, not the DIAG connector, is plugged in to the programming port on the RCM4300 with the marked 
(colored) edge of the programming cable towards pin 1 of the programming header.

• Ensure that the RCM4300 module is firmly and correctly installed in its socket on the Prototyping Board.

• If a program compiles and loads, but then loses target communication before you can begin debugging, it is 
possible that your PC cannot handle the default debugging baud rate. Locate the Serial Options dialog in the 
Dynamic C Options > Project Options > Communications menu. Choose a lower debug baud rate.

Press <Ctrl-Y> to force Dynamic C to recompile the BIOS. You should receive a Bios compiled 
successfully message once these steps are completed successfully. 

If there are any other problems:

• Use the Dynamic C Help menu to get further assistance with Dynamic C.

• Check the Rabbit Technical Bulletin Board and forums at www.rabbit.com/support/bb/ 
and at www.rabbit.com/forums/.

• Use the Technical Support e-mail form at www.rabbit.com/support/.

NOTE: If you purchased your Secure Embedded Web Application Kit through a distributor or through a 
Rabbit partner, contact the distributor or partner first for technical support.

Installing Dynamic C®

Insert the CD from the Application Kit in your 
oes 
ram 

.

Rabbit, RabbitCore, Dynamic C, and Digi are registered trademarks of Digi International Inc.
SD is a trademark of the SD Card Association.

Visit our online Rabbit store at www.rabbit.com/store/ for 
the latest information on peripherals and accessories that 
are available for the RCM4300 RabbitCore modules.

PC’s CD-ROM drive. If the installation d
not auto-start, run the setup.exe prog
in the root directory of the Dynamic C CD
Secure Embedded Web Application Kit 2.0
The Secure Embedded Web Application Kit allows you to develop a secure embedded Web interface for 
your embedded systems. The Application Kit is based on the RCM4300 RabbitCore module, which fea-
tures built-in Ethernet, a swappable flash memory device, and an optional A/D converter.

Application Kit Contents
• RabbbitCore® RCM4300 module.

• Prototyping Board.

• 512 MB miniSD™ Card with SD Card adapter

• Universal AC adapter, 12 V DC, 1 A (includes Canada/Japan/U.S., Australia/N.Z., U.K., and 
European style plugs).

• USB programming cable with 10-pin header.

• Cat. 5 Ethernet crossover cable.

• 10-pin header to DB9 serial cable.

• Secure Embedded Web Application Kit CD including Dynamic C®, FAT File System, RabbitWeb, Rabbit 
Embedded Security Pack, and sample programs and information related to the Secure Embedded Web 

http://www.zworld.com/support/bb/index.html
http://www.zworld.com/support/questionSubmit.shtml
http://www.rabbit.com/store/
http://www.rabbitsemiconductor.com/forums/


Hardware Connections
Step 1 — Prepare the Prototyping Board
To facilitate handling the Prototyping Board, snap in the 
four standoffs to the four holes at the corners from the 
bottom side of the Prototyping Board as shown in 
Figure 1.

NOTE: The hole at the bottom left of the Prototyping 
Board is used to mount the RCM4300, so use the 
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hole immediately above it for the standoff.

Step 2 — Insert the miniSD™ Card

Insert the miniSD™ Card.into the miniSD Card holder on 
the RCM4300. The card is designed to fit easily only one way — do not bend 
the card or force it into the slot.You will sense a soft click once the card is 
inserted completely.

Step 3 — Attach RCM4300 Module to Prototyping Board

Step 4 — Connect Programming Cable
The programming cable connects the RCM4300 to the PC running Dynamic C to download programs and to mon-

Turn the RCM4300 module so that the 
mounting holes line up with the correspond-
ing holes on the Prototyping Board. Insert 
the metal standoffs as shown in Figure 2, 
secure them from the bottom using the three 
screws and washers, then insert the module’s 
header J4 on the bottom side into socket 
RCM1 on the Prototyping Board.

NOTE: It is important that you line up the 
pins on header J4 of the module 
exactly with socket RCM1 on the Pro-
totyping Board. The header pins may 
become bent or damaged if the pin 
alignment is offset, and the module 
will not work. Permanent electrical 
damage to the module may also result 
if a misaligned module is powered up.

Press the module’s pins firmly into the Proto-
typing Board socket—press down in the area 
above the header pins. For additional integ-
rity, you may secure the RCM4300 to the 
standoffs from the top using the remaining 
three screws and washers.

Figure 2.  Install the RCM4300 Module
on the Prototyping Board

Figure 1.  Insert Standoffs
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CAUTION: You will sense a soft click 
once you insert the miniSD™ Card 
completely. To remove it, gently press 
the card towards the middle of the 
RCM4300 — you will sense a soft click 
and the card will be ready to be removed. 
Do not attempt to pull the card from the 
socket before pressing it in — otherwise 
the ejection mechanism will get dam-
aged. The ejection mechanism is spring-
loaded, and will partially eject the card 
when used correctly.
itor the RCM4300 module during debugging.
Connect the 10-pin connector of the programming cable labeled PROG to header J1 on the RCM4300 as shown in 
Figure 3. Be sure to orient the marked (usually red) edge of the cable towards pin 1 of the connector. (Do not use 
the DIAG connector, which is presently not supported by the RCM4300.)

http://www.ftdichip.com/Drivers/VCP.htm


Hardware Connections

Step 1 — Prepare the Prototyping Board

To facilitate handling the Prototyping Board, snap in the 
four standoffs to the four holes at the corners from the 
bottom side of the Prototyping Board as shown in 
Figure 1.

NOTE: The hole at the bottom left of the Prototyping 
Board is used to mount the RCM4300, so use the 
hole immediately above it for the standoff.

Step 2 — Insert the miniSD™ Card

Insert the miniSD™ Card.into the miniSD Card holder on 
the RCM4300. The card is designed to fit easily only one way — do not bend 
the card or force it into the slot.You will sense a soft click once the card is 
inserted completely.

Step 3 — Attach RCM4300 Module to Prototyping Board

Step 4 — Connect Programming Cable

The programming cable connects the RCM4300 to the PC running Dynamic C to download programs and to mon-
itor the RCM4300 module during debugging.

Connect the 10-pin connector of the programming cable labeled PROG to header J1 on the RCM4300 as shown in 
Figure 3. Be sure to orient the marked (usually red) edge of the cable towards pin 1 of the connector. (Do not use 
the DIAG connector, which is presently not supported by the RCM4300.)

Turn the RCM4300 module so that the 
mounting holes line up with the correspond-
ing holes on the Prototyping Board. Insert 
the metal standoffs as shown in Figure 2, 
secure them from the bottom using the three 
screws and washers, then insert the module’s 
header J4 on the bottom side into socket 
RCM1 on the Prototyping Board.

NOTE: It is important that you line up the 
pins on header J4 of the module 
exactly with socket RCM1 on the Pro-
totyping Board. The header pins may 
become bent or damaged if the pin 
alignment is offset, and the module 
will not work. Permanent electrical 
damage to the module may also result 
if a misaligned module is powered up.

Press the module’s pins firmly into the Proto-
typing Board socket—press down in the area 
above the header pins. For additional integ-
rity, you may secure the RCM4300 to the 
standoffs from the top using the remaining 
three screws and washers.

Figure 2.  Install the RCM4300 Module
on the Prototyping Board

Figure 1.  Insert Standoffs
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Figure 3.  Connect Programming Cable and Power Supply

Connect the other end of the programming cable to an available USB port on your PC or workstation.

Your PC should recognize the new USB hardware, and the LEDs in the shrink-wrapped area of the USB 
programming cable will flash — if you get an error message, you will have to install USB drivers. Drivers 
for Windows XP are available in the Dynamic C Drivers\Rabbit USB Programming Cable\
WinXP_2K folder — double-click DPInst.exe to install the USB drivers. Drivers for other operating 
systems are available online at www.ftdichip.com/Drivers/VCP.htm.

Step 5 — Connect Power

Once all the other connections have been made, you can connect power to the Prototyping Board. 
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First, prepare the AC adapter for the country where it will be used by selecting the plug. The RCM4300 
Development Kit presently includes Canada/Japan/U.S., Australia/N.Z., U.K., and European style plugs. 
Snap in the top of the plug assembly into the slot at the top of the AC adapter as shown in Figure 3, then 
press down on the spring-loaded clip below the plug assembly to allow the plug assembly to click into 
place. Release the clip to secure the plug assembly in the AC adapter.

Connect the AC adapter to 3-pin header J1 on the Prototyping Board as shown in Figure 3. The connector 
may be attached either way as long as it is not offset to one side—the center pin of J1 is always connected 
to the positive terminal, and either edge pin is ground.
Plug in the AC adapter. The PWR LED on the Prototyping Board next to the power connector at J1 should 
light up. The RCM4300 and the Prototyping Board are now ready to be used.

NOTE: A RESET button is provided on the Prototyping Board next to the battery holder to allow 
a hardware reset without disconnecting power.

http://www.ftdichip.com/Drivers/VCP.htm


Secure Embedded Web Application Kit 2.0
The Secure Embedded Web Application Kit allows you to develop a secure embedded Web interface for 
your embedded systems. The Application Kit is based on the RCM4300 RabbitCore module, which fea-
tures built-in Ethernet, a swappable flash memory device, and an optional A/D converter.

Application Kit Contents
• RabbbitCore® RCM4300 module.

• Prototyping Board.

• 512 MB miniSD™ Card with SD Card adapter

• Universal AC adapter, 12 V DC, 1 A (includes Canada/Japan/U.S., Australia/N.Z., U.K., and 
European style plugs).

• USB programming cable with 10-pin header.

• Cat. 5 Ethernet crossover cable.

• 10-pin header to DB9 serial cable.

• Secure Embedded Web Application Kit CD including Dynamic C®, FAT File System, RabbitWeb, Rabbit 
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Once the RCM4300 is connected as described in the preceding pages, start Dynamic C by double-clickin
Dynamic C icon on your desktop or in your Start menu. Select Code and BIOS in RAM on the “Com
tab in the Dynamic C Options > Project Options menu. Then click on the “Communications” tab an
that Use USB to Serial Converter is selected to support the USB programming cable. Click OK.

NOTE: The Code and BIOS in RAM BIOS memory compiler option is recommended whil
ging for faster download times. Remember to recompile the working application using the Co
BIOS in Flash, Run in RAM option once you are ready to use the RCM4300 in a standalo
lation.

Determine which COM port was assigned to the USB programming cable on your PC. Open Control P
System > Hardware > Device Manager > Ports and identify which COM port is used for the USB
tion. In Dynamic C, select Options > Project Options, then select this COM port on the Communic
tab, then click OK. You may type the COM port number followed by Enter on your computer keyboard if
COM port number is outside the range on the dropdown menu.

Use the File menu to open the sample program PONG.C, which is in the Dynamic C SAMPLES folder. P
function key F9 to compile and run the program.The STDIO window will open on your PC and will dis
small square bouncing around in a box.

Where Do I Go From Here?
If the sample program ran fine, you are now ready to go on to other sample programs, which are discuss
Application Note AN417, Secure Embedded Web Application Kit 2.0. The source code for the sample p
is provided to allow you to modify them for your own use. The RCM4300 User's Manual on the Dynam
also provides complete hardware reference information and describes the software function calls for the
RCM4300 RabbitCore modules and the Prototyping Board. Each Dynamic C module has complete docu
tion on the Dynamic C CD that describes the Dynamic C module and discusses the function calls and sam
grams associated with the Dynamic C module.

Troubleshooting
If Dynamic C cannot find the target system (error message "No Rabbit Processor Detected.

• Check that the RCM4300 is powered correctly — the red PWR LED on the Prototyping Board should
when the RCM4300 is mounted on the Prototyping Board and the AC adapter is plugged in.

• Check both ends of the programming cable to ensure that they are firmly plugged into the PC and the
connector, not the DIAG connector, is plugged in to the programming port on the RCM4300 with the
(colored) edge of the programming cable towards pin 1 of the programming header.

• Ensure that the RCM4300 module is firmly and correctly installed in its socket on the Prototyping Bo
Rabbit, RabbitCore, Dynamic C, and Digi are registered trademarks of Digi International Inc.
SD is a trademark of the SD Card Association.020–0138 • 080414–A

Embedded Security Pack, and sample programs and information related to the Secure Embedded Web 
Application Kit — with complete product documentation on disk.

• Getting Started instructions.

• Plastic and metal standoffs with 4-40 screws and washers.

• A bag of accessory parts for use on the Prototyping Board.

• Rabbit 4000 Processor Easy Reference poster.

• Registration card.

Visit our online Rabbit store at www.rabbit.com/store/ for 
the latest information on peripherals and accessories that 
are available for the RCM4300 RabbitCore modules.

• If a program compiles and loads, but then loses target communication before you can begin debugging, it is 
possible that your PC cannot handle the default debugging baud rate. Locate the Serial Options dialog in the 
Dynamic C Options > Project Options > Communications menu. Choose a lower debug baud rate.

Press <Ctrl-Y> to force Dynamic C to recompile the BIOS. You should receive a Bios compiled 
successfully message once these steps are completed successfully. 

If there are any other problems:

• Use the Dynamic C Help menu to get further assistance with Dynamic C.

• Check the Rabbit Technical Bulletin Board and forums at www.rabbit.com/support/bb/ 
and at www.rabbit.com/forums/.

• Use the Technical Support e-mail form at www.rabbit.com/support/.

NOTE: If you purchased your Secure Embedded Web Application Kit through a distributor or through a 
Rabbit partner, contact the distributor or partner first for technical support.

Installing Dynamic C®

Insert the CD from the Application Kit in your 
PC’s CD-ROM drive. If the installation does 
not auto-start, run the setup.exe program 
in the root directory of the Dynamic C CD.

http://www.zworld.com/support/bb/index.html
http://www.zworld.com/support/questionSubmit.shtml
http://www.rabbit.com/store/
http://www.rabbitsemiconductor.com/forums/
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